13 Replies Last post: Apr 15, 2008 12:16 PM by Stephen Friedrich  
Adrian Sosialuk Newbie 6 posts since
Apr 14, 2008
Currently Being Moderated

Apr 14, 2008 2:24 AM

Tomcat 6 and deployment

Hi everyone,

 

I decided to give IDEA a try and i have encountered first and the biggest problem - I can't

deploy my web application ... I have my previous Tomcat installation which came together

with Netbeans. As Tomcat HOME I use the directory where it got installed. Tomcat BASE

I use ~/.netbeans/6.1beta/apache-tomcat-6.0.16_base.

 

After I try to run the app, I get:

 

13-Apr-2008 23:21:18 org.apache.catalina.core.AprLifecycleListener init

INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/jdk1.6.0_05/jre/lib/i386/server:/usr/lib/jvm/jdk1.6.0_05/jre/lib/i386:/usr/lib/jvm/jdk1.6.0_05/jre/../lib/i386:.::/usr/java/packages/lib/i386:/lib:/usr/lib

13-Apr-2008 23:21:18 org.apache.coyote.http11.Http11Protocol init

INFO: Initializing Coyote HTTP/1.1 on http-8084

13-Apr-2008 23:21:18 org.apache.catalina.startup.Catalina load

INFO: Initialization processed in 647 ms

13-Apr-2008 23:21:18 org.apache.catalina.core.StandardService start

INFO: Starting service Catalina

13-Apr-2008 23:21:18 org.apache.catalina.core.StandardEngine start

INFO: Starting Servlet Engine: Apache Tomcat/6.0.16

13-Apr-2008 23:21:19 org.apache.catalina.core.StandardContext start

SEVERE: Error filterStart

13-Apr-2008 23:21:19 org.apache.catalina.core.StandardContext start

SEVERE: Context /myapp startup failed due to previous errors

13-Apr-2008 23:21:19 org.apache.catalina.core.StandardContext start

SEVERE: Error filterStart

13-Apr-2008 23:21:19 org.apache.catalina.core.StandardContext start

SEVERE: Context [] startup failed due to previous errors

13-Apr-2008 23:21:19 org.apache.coyote.http11.Http11Protocol start

INFO: Starting Coyote HTTP/1.1 on http-8084

13-Apr-2008 23:21:19 org.apache.jk.common.ChannelSocket init

INFO: JK: ajp13 listening on /0.0.0.0:8009

13-Apr-2008 23:21:19 org.apache.jk.server.JkMain start

INFO: Jk running ID=0 time=0/18  config=null

13-Apr-2008 23:21:19 org.apache.catalina.startup.Catalina start

INFO: Server startup in 543 ms

Connected to server

 

Could anybody please help me ?

 

Cheers,

 

Adrian

Anonymous OmniaMea User Apprentice 1,036 posts since
Aug 2, 2004
Currently Being Moderated
Apr 14, 2008 3:19 AM in response to: Adrian Sosialuk
Re: Tomcat 6 and deployment

Nothing wrong with that.

You have an INFO message stating that APR library wasn't found. If you

start Tomcat standalone, you will get the same message.

Last line indicates that Tomcat has started.

 

Anonymous OmniaMea User Apprentice 1,036 posts since
Aug 2, 2004
Currently Being Moderated
Apr 14, 2008 9:18 AM in response to: Adrian Sosialuk
Re: Tomcat 6 and deployment
Guest
Currently Being Moderated
Apr 14, 2008 10:15 AM in response to: Adrian Sosialuk
Re: Tomcat 6 and deployment

@TomP: I think you are wrong.

While it's true that the message about the missing native library can be ignore, there is definitely something wrong going on here.

If you look a couple of lines lower, you'll find

    "SEVERE: Error filterStart"

and

    "SEVERE: Context [] startup failed due to previous errors"

 

@Adrian: Look at the other log files that tomcat and your application are writing.

There must be another error somewhere.

 

 

Adrian Sosialuk wrote:

Hi everyone,

 

I decided to give IDEA a try and i have encountered first and the biggest problem - I can't

deploy my web application ... I have my previous Tomcat installation which came together

with Netbeans. As Tomcat HOME I use the directory where it got installed. Tomcat BASE

I use ~/.netbeans/6.1beta/apache-tomcat-6.0.16_base.

 

After I try to run the app, I get:

 

13-Apr-2008 23:21:18 org.apache.catalina.core.AprLifecycleListener init

INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/jdk1.6.0_05/jre/lib/i386/server:/usr/lib/jvm/jdk1.6.0_05/jre/lib/i386:/usr/lib/jvm/jdk1.6.0_05/jre/../lib/i386:.::/usr/java/packages/lib/i386:/lib:/usr/lib

13-Apr-2008 23:21:18 org.apache.coyote.http11.Http11Protocol init

INFO: Initializing Coyote HTTP/1.1 on http-8084

13-Apr-2008 23:21:18 org.apache.catalina.startup.Catalina load

INFO: Initialization processed in 647 ms

13-Apr-2008 23:21:18 org.apache.catalina.core.StandardService start

INFO: Starting service Catalina

13-Apr-2008 23:21:18 org.apache.catalina.core.StandardEngine start

INFO: Starting Servlet Engine: Apache Tomcat/6.0.16

13-Apr-2008 23:21:19 org.apache.catalina.core.StandardContext start

SEVERE: Error filterStart

13-Apr-2008 23:21:19 org.apache.catalina.core.StandardContext start

SEVERE: Context /myapp startup failed due to previous errors

13-Apr-2008 23:21:19 org.apache.catalina.core.StandardContext start

SEVERE: Error filterStart

13-Apr-2008 23:21:19 org.apache.catalina.core.StandardContext start

SEVERE: Context [] startup failed due to previous errors

13-Apr-2008 23:21:19 org.apache.coyote.http11.Http11Protocol start

INFO: Starting Coyote HTTP/1.1 on http-8084

13-Apr-2008 23:21:19 org.apache.jk.common.ChannelSocket init

INFO: JK: ajp13 listening on /0.0.0.0:8009

13-Apr-2008 23:21:19 org.apache.jk.server.JkMain start

INFO: Jk running ID=0 time=0/18  config=null

13-Apr-2008 23:21:19 org.apache.catalina.startup.Catalina start

INFO: Server startup in 543 ms

Connected to server

 

Could anybody please help me ?

 

Cheers,

 

Adrian

 

Anonymous OmniaMea User Apprentice 1,036 posts since
Aug 2, 2004
Currently Being Moderated
Apr 14, 2008 10:26 AM in response to: Stephen Friedrich
Re: Tomcat 6 and deployment

You are right. I scanned the output too quickly, and missed SEVERE.

 

Guest
Currently Being Moderated
Apr 15, 2008 12:26 AM in response to: Adrian Sosialuk
Re: Tomcat 6 and deployment

Seems like netbeans polluted you tomcat installation.

A quick google search brought up this:

http://www.mail-archive.com/tomcat-user@jakarta.apache.org/msg100069.html//www.mail-archive.com/tomcat-user@jakarta.apache.org/msg100069.html

 

(See also the other answer at the bottom.)

 

Adrian Sosialuk wrote:

Hi Tim,

 

Thanks for your reply.

 

I still can not get Tomcat working with IDEA.

I don't have such issues with Netbeans or Eclipse.

 

Nothing gets written to log files directly (checked HOME and BASE directory).

 

I get only this on output:

 

Tomcat log:

 

14-Apr-2008 17:43:45 org.apache.catalina.core.StandardContext filterStart

SEVERE: Exception starting filter HTTPMonitorFilter

java.lang.ClassNotFoundException: org.netbeans.modules.web.monitor.server.MonitorFilter

     at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1360)

     at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1206)

     at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:249)

     at org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(ApplicationFilterConfig.java:397)

     at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:108)

     at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:3709)

     at org.apache.catalina.core.StandardContext.start(StandardContext.java:4356)

     at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)

     at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)

     at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:525)

     at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:626)

     at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:553)

     at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:488)

     at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1147)

     at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)

     at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)

     at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)

     at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)

     at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)

     at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)

     at org.apache.catalina.core.StandardService.start(StandardService.java:516)

     at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)

     at org.apache.catalina.startup.Catalina.start(Catalina.java:578)

     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

     at java.lang.reflect.Method.invoke(Method.java:597)

     at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)

     at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)

 

The above repeats 3 times.

 

 

Console:

 

/home/adrian/apache-tomcat-6.0.16/bin/catalina.sh run

14-Apr-2008 17:43:44 org.apache.catalina.core.AprLifecycleListener init

INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java..library.path: /usr/lib/jvm/jdk1.6.0_05/jre/lib/i386/server:/usr/lib/jvm/jdk1.6.0_05/jre/lib/i386:/usr/lib/jvm/jdk1.6.0_05/jre/../lib/i386:.::/usr/java/packages/lib/i386:/lib:/usr/lib

14-Apr-2008 17:43:44 org.apache.coyote.http11.Http11Protocol init

INFO: Initializing Coyote HTTP/1.1 on http-8084

14-Apr-2008 17:43:44 org.apache.catalina.startup.Catalina load

INFO: Initialization processed in 607 ms

14-Apr-2008 17:43:44 org.apache.catalina.core.StandardService start

INFO: Starting service Catalina

14-Apr-2008 17:43:44 org.apache.catalina.core.StandardEngine start

INFO: Starting Servlet Engine: Apache Tomcat/6.0.16

14-Apr-2008 17:43:45 org.apache.catalina.core.StandardContext start

SEVERE: Error filterStart

14-Apr-2008 17:43:45 org.apache.catalina.core.StandardContext start

SEVERE: Context /adrianeczek startup failed due to previous errors

14-Apr-2008 17:43:45 org.apache.catalina.core.StandardContext start

SEVERE: Error filterStart

14-Apr-2008 17:43:45 org.apache.catalina.core.StandardContext start

SEVERE: Error filterStart

14-Apr-2008 17:43:45 org.apache.catalina.core.StandardContext start

SEVERE: Context [] startup failed due to previous errors

14-Apr-2008 17:43:45 org.apache.coyote.http11.Http11Protocol start

INFO: Starting Coyote HTTP/1.1 on http-8084

14-Apr-2008 17:43:45 org.apache.jk.common.ChannelSocket init

INFO: JK: ajp13 listening on /0.0.0.0:8009

14-Apr-2008 17:43:45 org.apache.jk.server.JkMain start

INFO: Jk running ID=0 time=0/48  config=null

14-Apr-2008 17:43:45 org.apache.catalina.startup.Catalina start

INFO: Server startup in 445 ms

Connected to server

/home/adrian/apache-tomcat-6.0.16/bin/catalina.sh stop

14-Apr-2008 17:43:56 org.apache.coyote.http11.Http11Protocol pause

INFO: Pausing Coyote HTTP/1.1 on http-8084

14-Apr-2008 17:43:57 org.apache.catalina.core.StandardService stop

INFO: Stopping service Catalina

14-Apr-2008 17:43:57 org.apache.coyote.http11.Http11Protocol destroy

INFO: Stopping Coyote HTTP/1.1 on http-8084

Disconnected from server

 

Any idea what it might be ?

 

Cheers,

 

Adrian

 

Mark Vedder Apprentice 1,020 posts since
Dec 10, 2003
Currently Being Moderated
Apr 15, 2008 5:45 AM in response to: Stephen Friedrich
Re: Tomcat 6 and deployment

Corrected link:  http://tinyurl.com/438sun

 

(The link contains an email address since its a mailing list archive, but this forum software wants to obfuscate it from spiders, so the link it displays above does not work; you can just reverse the obfuscation, but I thought a tiny URL would make it easier on folks.)

Mark Vedder Apprentice 1,020 posts since
Dec 10, 2003
Currently Being Moderated
Apr 15, 2008 5:46 PM in response to: Mark Vedder
Re: Tomcat 6 and deployment

p.s. if we were keeping score, would that be:

-10 for Netbeans for polluting a Tomcat install

-1 for Eclipse for not displaying the error message on startup

+1 for IDEA for displaying the error on startup.

 

  - sorry, I couldn't resit

Guest
Currently Being Moderated
Apr 15, 2008 12:16 PM in response to: Mark Vedder
Re: Tomcat 6 and deployment

Did not notice that: The link is working fine if you read the messages via JetBrain's newsgroup server.

 

Mark Vedder wrote:

Corrected link:  http://tinyurl.com/438sun

 

(The link contains an email address since its a mailing list archive, but this forum software wants to obfuscate it from spiders, so the link it displays above does not work; you can just reverse the obfuscation, but I thought a tiny URL would make it easier on folks.)

 

More Like This

  • Retrieving data ...