7 Replies Last post: Feb 26, 2010 2:09 AM by Bart Teeuwisse  
Jim Oser Newbie 2 posts since
Jan 11, 2010
Currently Being Moderated

Jan 11, 2010 10:07 AM

ruby version manager (rvm) with RubyMine 2.0

What is the correct way of using ruby version manager (rvm) ( http://rvm.beginrescueend.com/ ) with RubyMine 2.0 and Mac OS X 10.5.x?

 

What about with Mac OS X 10.6.x?

 

Can I use Preferences --> Ruby SDK and Gems --> and then Add SDK?

 

Or do I need to invoke RubyMine 2.0 from the command line?

 

Or do I need to do something like this:

http://www.jetbrains.net/devnet/docs/DOC-1160  ?

Dennis Ushakov JetBrains 408 posts since
Sep 10, 2008
Currently Being Moderated
Jan 11, 2010 6:10 PM in response to: Jim Oser
Re: ruby version manager (rvm) with RubyMine 2.0

You can simply open your project and RubyMine should pick all your sdk's installed via RVM automatically. If it doesn't work, feel free to file a bug report (please describe rvm version, installation directory and installed ruby interpreters) and add sdk manually with add sdk button.

Roman.Chernyatchik  JetBrains 1,452 posts since
Sep 18, 2007
Currently Being Moderated
Jan 14, 2010 1:18 PM in response to: Jim Oser
Re: ruby version manager (rvm) with RubyMine 2.0

RubyMine should automatically detect rvm SDKs using (~/.rvm information) and you needn't add SDK manually using "add sdk" button. If you add new sdk to rvm you should just relaunch RubyMine. If your RubyMine's behaviour differs from this than it is some RubyMine bug and we should fix it.

Joe Duhamel Newbie 1 posts since
Nov 6, 2002
Currently Being Moderated
Jan 21, 2010 3:55 AM in response to: Roman.Chernyatchik
Re: ruby version manager (rvm) with RubyMine 2.0

Hi Roman,

 

I just did an install of RubyMine 2.0 and 2.0.1 along with a fresh rvm 0.999 (which is the latest) When I go to the RubyMine preferences there are no entries in the SDK dropdown. If I understand your comment. I should file a bug report? Was I supposed to do anything else to populate/add the sdk's?

 

-Joe

j c Newbie 3 posts since
Feb 5, 2010
Currently Being Moderated
Feb 5, 2010 11:27 AM in response to: Joe Duhamel
Re: ruby version manager (rvm) with RubyMine 2.0

I'm having the same problem on Rubymine 2.0.1. It doesnt recognize RVM in the dropdown.

 

If I select the RVM location manually (~/.rvm/rubies/...../bin),  it works. However, it fails whenever trying to install native gems. Works fine when I install them from command line.

 

Please help

Roman.Chernyatchik  JetBrains 1,452 posts since
Sep 18, 2007
Currently Being Moderated
Feb 9, 2010 8:26 PM in response to: j c
Re: ruby version manager (rvm) with RubyMine 2.0

I've filed an issue - http://youtrack.jetbrains.net/issue/RUBY-5750. Our rvm support was implemented for some early version of rvm with different files layout in ~/.rvm directory. We are going to fix our rvm support in coming 2.0.2 version.

 

P.S: I've just fixed rvm support and tried to install native ruby-debug-ide19 gem in ruby19 rvm-based sdk. It seems all works fine!

Bart Teeuwisse Newbie 3 posts since
Feb 25, 2010
Currently Being Moderated
Feb 26, 2010 2:09 AM in response to: Roman.Chernyatchik
Re: ruby version manager (rvm) with RubyMine 2.0

I'm running into similar issues when trying to add a Ruby SDK in IDEA 9.0 (Ultimate) or RubyMine 2.0.1. Neither one is aware of rvm and worse I can't add interpreters located in ~/.rvm. Both simply always uses /usr/bin/ruby, no matter which path I enter in the Select Path dialog.

More Like This

  • Retrieving data ...