8 Replies Last post: Apr 5, 2011 10:34 PM by Andrey Serebryansky  
Tom Cabanski Newbie 9 posts since
Sep 28, 2009
Currently Being Moderated

Dec 7, 2010 4:37 PM

Nunit test runner fails trying to load an assembly from AppData

I am on 5.1.1760.3.  I am using a project with NUnit 2.5.8.  I have configured the NUnit test runner to use the default installation path.  I tried this with shadow copying both on and off with the same results.  The dll does load and test fine from the NUnit GUI.  However, when I try to run the tests via resharper I get the following dialog:

 

Unit Test Runner failed to load test assembly

JetBrains.Resharper.TaskRunnerFramework.TaskException: Could not

load file or assembly

file:///c:\users\me\AppData\Local\Temp\ppyijgad.utc or one of its dependencies. 

The system cannot find the file specified.

 

The last part of the file path in AppData is different any time.  This is an empty project with just one sample test. 

 

Any idea what is causing this and how I can solve it?

Andrey Serebryansky JetBrains 2,900 posts since
Jan 12, 2005
Currently Being Moderated
Dec 8, 2010 5:03 PM in response to: Tom Cabanski
Re: Nunit test runner fails trying to load an assembly from AppData

Hello Tom,

 

Could you please attach a screenshot of the message and a screenshot of Debug

| Exceptions window? Thank you!

 

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

 

I am on 5.1.1760.3.  I am using a project with NUnit 2.5.8.  I have

configured the NUnit test runner to use the default installation path.

I tried this with shadow copying both on and off with the same

results.  The dll does load and test fine from the NUnit GUI.

However, when I try to run the tests via resharper I get the following

dialog:

 

Unit Test Runner failed to load test assembly

JetBrains.Resharper.TaskRunnerFramework.TaskException: Could not

load file or assembly

file:///c:\users\me\AppData\Local\Temp\ppyijgad.utc or one of its

dependencies.

The system cannot find the file specified.

The last part of the file path in AppData is different any time.  This

is an empty project with just one sample test.

 

Any idea what is causing this and how I can solve it?

 

---

Original message URL:

http://devnet.jetbrains.net/message/5279977#5279977

 

 

 

Andrey Serebryansky JetBrains 2,900 posts since
Jan 12, 2005
Currently Being Moderated
Dec 13, 2010 1:58 PM in response to: Tom Cabanski
Re: Nunit test runner fails trying to load an assembly from AppData

Hello Tom,

 

Have you tried turning off the 'Shadow copy assemblies being tested' option

under ReSharper | Options | Unit Testing? Thank you!

 

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

 

Hello Andrey,

 

I have attached the requested screen shots.

 

Exceptions window:

 

Image:debugExcptionsWindow.png ''

The error message:

Image:unitTestErrorMessage.png

 

---

Original message URL:

http://devnet.jetbrains.net/message/5280469#5280469

 

 

 

Ben Pope Newbie 2 posts since
Jan 5, 2011
Currently Being Moderated
Jan 7, 2011 2:53 PM in response to: Andrey Serebryansky
Re: Nunit test runner fails trying to load an assembly from AppData

In the first post it says: "I tried this with shadow copying both on and off with the same results."

 

I'm also having this problem with both NUnit 2.5.8 and 2.5.9.

 

I would like to get this fixed because it seems the test runner is not properly supporting the parameterised tests from NUnit, I'm yet to whittle it down, but I'm getting only around 1/5th of the tests that nunit console produces.

Brad Williams Newbie 3 posts since
Apr 5, 2011
Currently Being Moderated
Apr 5, 2011 12:09 AM in response to: Ben Pope
Re: Nunit test runner fails trying to load an assembly from AppData

I see the same error kind of error message (about Temp files) when trying to Run Unit Tests and using NUnit 2.5.9, but not with 2.5.7.

Andrey Serebryansky JetBrains 2,900 posts since
Jan 12, 2005
Currently Being Moderated
Apr 5, 2011 1:22 PM in response to: Brad Williams
Re: Nunit test runner fails trying to load an assembly from AppData

Hello Brad,

 

Which version of ReSharper do you use? Thank you!

 

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

 

I see the same error kind of error message (about Temp files) when

trying to Run Unit Tests and using NUnit 2.5.9, but not with 2.5.7.

 

---

Original message URL:

http://devnet.jetbrains.net/message/5299269#5299269

 

 

 

Brad Williams Newbie 3 posts since
Apr 5, 2011
Currently Being Moderated
Apr 5, 2011 10:04 PM in response to: Andrey Serebryansky
Re: Nunit test runner fails trying to load an assembly from AppData

I am using 5.0.1659.36 of Resharper C# Edition

Andrey Serebryansky JetBrains 2,900 posts since
Jan 12, 2005
Currently Being Moderated
Apr 5, 2011 10:34 PM in response to: Brad Williams
Re: Nunit test runner fails trying to load an assembly from AppData

Hello Brad,

 

ReSharper 5.x doesn't support NUnit 2.5.9. It will be supported in the upcoming

ReSharper 6. You can already download the early builds at http://tinyurl.com/6jrespl.

Thank you!

 

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

 

I am using 5.0.1659.36 of Resharper C# Edition

 

---

Original message URL:

http://devnet.jetbrains.net/message/5299416#5299416

 

 

 

More Like This

  • Retrieving data ...