This Question is Answered

1 "correct" answer available (4 pts) 2 "helpful" answers available (2 pts)
2 Replies Last post: Aug 16, 2012 8:35 PM by Patrick Garner  
Patrick Garner Newbie 16 posts since
Mar 12, 2012
Currently Being Moderated

Aug 15, 2012 12:30 AM

IDEA 11.1.3 opens two browser windows during deployment

In the past two days IDEA has begun opening two browser windows when deploying an exploded WAR for JBoss.  IDEA opens the first browser window while JBoss is still starting up and the browser window displays a 404 error.  This has not happened before.  The second browser window opens up at the appropriate time and displays the welcome page for my web application.  The other configuration I use, for normal WAR deployment, continues to work fine (doesn't open two browser windows).  I looked in my JBoss server run/debug configurations and they look fine.  How to fix this problem?

Michael Golubev JetBrains 92 posts since
Mar 27, 2012
Currently Being Moderated
Aug 16, 2012 7:59 PM in response to: Patrick Garner
Re: IDEA 11.1.3 opens two browser windows during deployment

Hello,

 

I can't reproduce this.

Could you please provide:

1) your JBoss version
2) screenshot of the run configuration
3) complete text content of the Output tab of the run configuration tool window
4) what is the URL being opened at the first time? is it the same as shown in the run configuration and the one opened at the second time?

 

Regards,

Michael

More Like This

  • Retrieving data ...