11 Replies Last post: Nov 11, 2013 8:33 PM by Santiago Tzonpalntli  
Bob Gustafson Newbie 78 posts since
Jan 4, 2011
Currently Being Moderated

Jun 5, 2011 11:00 PM

Error running.. Rails server launcher wasn't found in project

Hi

 

I'm having a little trouble getting back in the saddle after upgrading my OS to Fedora 15.

 

I did an install of F15 from scratch, so I had to reload my workspace and RubyMine from backups.

 

I also have rvm installed (as before) although am not quite certain that it is installed correctly.

 

RVM is installed as a globally (my computer anyway) available in /usr/local/rvm

 

After copying over the RubyMine 3.1 files, I upgraded to 3.1.1rc and then typed in my license key.

 

It took a few times through gem installs and recognizing Gemfile, but all of that seems to be fixed.

 

I just have the problem noted in my Subject Header - Rails server launcher wasn't found in project.

 

rack seems to be there...

 

----

 

Any suggestions on how I might proceed?

Bryan Abbott Newbie 4 posts since
Jun 7, 2011
Currently Being Moderated
Jun 7, 2011 11:50 AM in response to: Bob Gustafson
Re: Error running.. Rails server launcher wasn't found in project

Bob,

 

I downloaded the trial to play around with and seem to be having a similar problem.

 

I'm trying to run/debug older rails apps around 2.3.8 and get the same error. 

 

I suspect it might have something to do with my .rvm configuration.  I've set the default rvm environment to ruby-1.8.7-p334 [ x86_64 ]

but from the console I've always had to force "rvm use 1.8.7" for everything to work correctly.  

 

I'd like to play around with RubyMine but I'm not in the mood for time sinks.  I'm less than a year into Ruby dev, and I think

my .profile or .rvm config settings are incorrect. 

 

I'll let you know if I get anywhere with it.

 

Bryan Abbott Newbie 4 posts since
Jun 7, 2011
Currently Being Moderated
Jun 7, 2011 1:28 PM in response to: Bryan Abbott
Re: Error running.. Rails server launcher wasn't found in project

Still can't get this working.

 

I resolved my .rvm problem as some settings were attempting to load from /etc/profile instead of my user profile.

 

Can anyone help ?

Roman.Chernyatchik  JetBrains 1,452 posts since
Sep 18, 2007
Currently Being Moderated
Jun 8, 2011 5:15 PM in response to: Bryan Abbott
Re: Error running.. Rails server launcher wasn't found in project

Hi Bryan,

 

Please check that only rails 2.3.8 version is attached in RubyMine | File | Settings | Ruby Sdk And GemsManager settings. Such error may occur when RubyMine expected 3.x version when you have 2.3.x rails server launcher scripts in ./scripts folder and vice versa. Or better try RubyMine 3.1.1 as far as I remember we've already updated this message and new version explains the problem.

Bryan Abbott Newbie 4 posts since
Jun 7, 2011
Currently Being Moderated
Jun 8, 2011 6:08 PM in response to: Roman.Chernyatchik
Re: Error running.. Rails server launcher wasn't found in project

Roman,

 

Thank you for the response.  I am evaluating 3.1.1.  Rails 2.3.8 is the only gem installed for this project.

 

Am I missing something here?  I searched the web and your forums for some leads without success.

 

- B

Bryan Abbott Newbie 4 posts since
Jun 7, 2011
Currently Being Moderated
Jun 9, 2011 8:00 AM in response to: Bob Gustafson
Re: Error running.. Rails server launcher wasn't found in project

Bob,

 

I'm not sure.  I guess I expected the IDE to recognize these situations a bit more elegantly. 

My project sounds similar as it has multiple submodules.  None however should be requiring a rails 3.0 server. 

 

I tried to "import" a project from github thinking the project creation process might correct something instead of me just

opening folder as a project. 

 

Overall the process has been as much fun as MS Visual Studio 2003.  I think I'll be heading back to TextMate. 

 

Intellisense sounded nice there for a while ... Maybe I'll run into someone a bit more fluent with RubyMine down the road and I'll give it another shot.

Roman.Chernyatchik  JetBrains 1,452 posts since
Sep 18, 2007
Currently Being Moderated
Jun 10, 2011 12:03 AM in response to: Bryan Abbott
Re: Error running.. Rails server launcher wasn't found in project

I'm not sure.  I guess I expected the IDE to recognize these situations a bit more elegantly.

My project sounds similar as it has multiple submodules.  None however should be requiring a rails 3.0 server. 

 

I tried to "import" a project from github thinking the project creation process might correct something instead of me just

opening folder as a project. 

 

Overall the process has been as much fun as MS Visual Studio 2003.  I think I'll be heading back to TextMate. 

 

Intellisense sounded nice there for a while ... Maybe I'll run into someone a bit more fluent with RubyMine down the road and I'll give it another shot.

RubyMine expects that Rails application is your project directory. If you have some folder "my_projects" which contains "my_rails_app" subfolder and some other usefull subfolders/subprojects. You need to

1. Open your "my_rails_app" as a project (RubyMine | File | Open Directory)

2. Then you may add additional project content roots in RubyMine | File | Settings | Project Structure. But your primary rails application should be a first root.

3. If needed you can tell RubyMine that checkout directory isn't a "my_rails_app" and is located in upper folder (see Settings | Version Control | VCS)

Artur Bilski Newbie 1 posts since
Nov 22, 2012
Currently Being Moderated
Nov 22, 2012 10:07 PM in response to: Roman.Chernyatchik
Re: Error running.. Rails server launcher wasn't found in project

Hi guys,

 

Simplest solution is to close the project, remove .idea folder and reopen the project.

 

Cheers!

Santiago Tzonpalntli Newbie 1 posts since
Nov 11, 2013
Currently Being Moderated
Nov 11, 2013 8:33 PM in response to: Bob Gustafson
Re: Error running.. Rails server launcher wasn't found in project

Hi everyone

Finally i found a solution.

 

I had have the same problem over and over again, and finally i found a not fancy solution!

Well when i had tried to running  with a proyect made before for example in ruby 1.9.3 and rails 3.2.13, rubymine throws the error "

'Error running.. Rails server launcher wasn't found in project'

however, i tried to build a  proyect in rubymine since the begining new proyect, railsproyect, etc, etc, etc, and when a running the proyect its work perfectly, no message was thorwed by rubymine, even  i ran the proyect in the brower (https://localhost:3000).

Well so i went to the path of my rubyonrails rubymine proyect and  i removed all the files and i did copy all the files from my first proyect (the proyect with the error) and voila! i restart the server and its work my proyect!

The only thing that i had to do it was to create a  rubyonrails proyect in rubymine and later remove the generate files from rubymine and copy and page the files from my original proyect with the error (rails server launcher) in the  folder of the proyect that i was created with rubymine.

 

If anybody else could found an error with this solution, please give my an info please.

More Like This

  • Retrieving data ...