This Question is Possibly Answered

1 "correct" answer available (4 pts) 2 "helpful" answers available (2 pts)
8 Replies Last post: Oct 27, 2014 4:28 PM by Maria Serebryansky  
Nick Evgeniev Newbie 19 posts since
Sep 30, 2002
Currently Being Moderated

Oct 13, 2011 1:49 AM

99% in native or optimized code. help needed

Hi,

 

I have a problem with dotTrace...

JetBrains dotTrace Performance 4.5.1 Professional Edition

Build 4.5.922.8 on 2011-08-03T20:55:00

If I run it in samling mode I got 99% in native or optimized code in snapshot (which is not true obviously).. which makes it absolutely useless... I mean while it's possible to have native method call (or callback) in stacktrace it doesn't mean that I'm not interested to know which methods are calling  'native or optimized code'...

 

I'm running win7x64 .net4

 

Needless to say that in tracing mode I don't see these native mode but it's so much slower compared to sampling mode (which is also terribly slow) that it's not possible to profile real life scenario...

 

Any ideas of how to deal with 'native or optimized code' ???

Andrey Serebryansky JetBrains 2,900 posts since
Jan 12, 2005
Currently Being Moderated
Oct 17, 2011 12:13 PM in response to: Nick Evgeniev
Re: 99% in native or optimized code. help needed

Hello Nick

 

Sorry for delayed response! This is a known problem and you're welcome to monitor its status at http://youtrack.jetbrains.net/issue/DTRC-6018.

 

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

Steven Padfield Newbie 4 posts since
Mar 26, 2013
Currently Being Moderated
Mar 26, 2013 4:42 AM in response to: Andrey Serebryansky
Re: 99% in native or optimized code. help needed

I am seeing the same problem with dotTrace 5.3.1 when profiling IIS Applications. I need help!

Thomas Tikwinski Newbie 2 posts since
Sep 29, 2014
Currently Being Moderated
Sep 29, 2014 6:35 PM in response to: Steven Padfield
Re: 99% in native or optimized code. help needed

Same effect here, using dotTrace 5.5:

 

Attaching to w3p shows 99% in native or optimized code, and Tracing mode is N/A.

 

Reading other threads in this forum, I'd presume the issue was resolved long ago. Does it still affect V5.5?

Is there anything I could be doing wrong?

 

I've attached some logs, any help would be highly appreciated.

 

Regards,

Thomas

Maria Serebryansky Newbie 33 posts since
May 15, 2014
Currently Being Moderated
Oct 2, 2014 10:30 AM in response to: Thomas Tikwinski
Re: 99% in native or optimized code. help needed

Hello Thomas,

 

Did your application work fine and produce some results during the profiling session?

Could you please perform an experiment? Try to profile our demo application the same way you profiled your own application and send us the corresponding log files.

 

 

Kind regards,
Maria

Maria Serebryansky Newbie 33 posts since
May 15, 2014
Currently Being Moderated
Oct 27, 2014 4:16 PM in response to: Thomas Tikwinski
Re: 99% in native or optimized code. help needed

Hello Thomas,


Sorry for the delay. According to the information in the log files, there were no errors during profiling, all operations were correctly performed and completed. Is it possible for you to attach or send us your snapshot with suspicious results?

 


Kind regards,
Maria

Steven Padfield Newbie 4 posts since
Mar 26, 2013
Currently Being Moderated
Oct 24, 2014 3:31 AM in response to: Steven Padfield
Re: 99% in native or optimized code. help needed

Is there any update on this? I am still unable to use your product. I am on version 5.5.4. I have never gotten a useful trace from it.

Maria Serebryansky Newbie 33 posts since
May 15, 2014
Currently Being Moderated
Oct 27, 2014 4:28 PM in response to: Steven Padfield
Re: 99% in native or optimized code. help needed

Hello Steven,

 

Could you please attach a snapshot with suspicios results?

 


Kind regards,
Maria

More Like This

  • Retrieving data ...