2 Replies Last post: Mar 7, 2012 5:54 PM by Geir-Magnus Pettersen  
Geir-Magnus Pettersen Newbie 13 posts since
Jul 12, 2010
Currently Being Moderated

Feb 22, 2012 3:45 AM

Problem with Visual Studio plugin when doing remote run

After having used a buildconfiguration for doing remote runs from visual studio for months we suddenly had a problem today. We use TFS as the VCS root. THe problem is the following:

  • I change some files in my solution and select the remote run option under teamcity menu in visual studio
  • The local changes dialog work as expected and I can choose wich files I want to process with my remote run
  • When I select the play button (configure personal build) on the local changes dialog I get the following error message:

error_no_build_config.png

  • In the %Temp%/jetlogs i find the following message:

 

 

00:29:15.831: Thread:1: [TFS, Workspace] Located version control type - Microsoft.VisualStudio.TeamFoundation.VersionControl.VersionControlExt

00:29:15.831: Thread:1: [TFS, Workspace] Located version control type assembly - Microsoft.VisualStudio.TeamFoundation.VersionControl.VersionControlExt, Microsoft.VisualStudio.TeamFoundation.VersionControl, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a

00:29:16.077: Thread:1: EXCEPTION: Error in the application.

 

JetBrains.TeamCity.EventTrackers.NoSuitableConfigurationsException: Error in the application.

 

   at JetBrains.TeamCity.RemoteRun.PersonalBuild.PersonalBuildConfigurator.DoConfigurePersonalBuild(IEnumerable`1 pendingChanges, String dialogTitle) in c:\BuildAgent\work\2e0eafe570b487fe\src\TeamCity.RemoteRun\src\PersonalBuild\PersonalBuildConfigurator.cs:line 133

   at JetBrains.TeamCity.RemoteRun.PersonalBuild.PersonalBuildConfigurator.<>c__DisplayClass2.<ConfigurePersonalBuild>b__0() in c:\BuildAgent\work\2e0eafe570b487fe\src\TeamCity.RemoteRun\src\PersonalBuild\PersonalBuildConfigurator.cs:line 71

 

  • We are currently using teamcity version 6.5.1.
  • Teamcity can detect changes made by manual checkin in visual studio or tfs and I can do manual run on the teamcity server.
  • The problem seem to be somewhere between the visual studio addin and the teamcity server.
  • The problem is the same for all users and all build configurations on the teamcity server.

 

Anoyone experienced the same problems or have som tips on where to start looking?

Evgeniy Koshkin JetBrains 57 posts since
Jan 17, 2011
Currently Being Moderated
Mar 7, 2012 5:10 PM in response to: Geir-Magnus Pettersen
Re: Problem with Visual Studio plugin when doing remote run

Marnus, I'm sorry for delay in reply.

Could you please send me full TeamCity Addin's log. You could post it here, if applicable, or send it to me by e-mail.

Also please check that all requirements, described in error dialog were sutisfied. Please note, that TFS settings are case-sensitive.

Also you could try to toggle 'Filter By Current Solution' option in main TeamCity menu and look at the MyChanges tool window for changes commited by you to TFS manually.

More Like This

  • Retrieving data ...