2 Replies Last post: 2012-3-30 下午8:14 by Leonid Shirmanov  
Leonid Shirmanov Newbie 8 posts since
2011-11-14
Currently Being Moderated

2012-3-29 下午6:15

Can't get RemoteAgent running as Windows Service

Hello there,

 

dotTrace itself is installed to C:\Program Files (x86)\JetBrains\dotTrace\v5.0\Bin, which is by default.

So the remote agent is located in C:\Program Files (x86)\JetBrains\dotTrace\v5.0\Bin\Remote and the web service is in C:\Program Files (x86)\JetBrains\dotTrace\v5.0\Bin\Remote\RemoteAgent.WebService.

 

When I run RemoteAgent.exe from a command line it's OK.

 

I install it by executing "installutil /i RemoteAgent.exe" and it actually appears in Services with the stopped state, which is OK as well at this point I suppose.

Then I click Start and in 10 minutes of being in Starting state I get following messages in System event log:

 

"A timeout was reached (600000 milliseconds) while waiting for the JetBrains Profiler Remote Agent service to connect."

"The JetBrains Profiler Remote Agent service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion."

 

Playing with a log file I've figured out it expects App path to be in "C:\Windows\system32\RemoteAgent.WebService"

I've also tried to specify Start parameters for the windows service like the following but according to the log it seems to ignore them completely, event I use just /port=9001

 

/log /port=9001 /appdir="C:\Program Files (x86)\JetBrains\dotTrace\v5.0\Bin\Remote\RemoteAgent.WebService"

 

Could you please assist in configuring the windows service and bringing it up and running?

 

Thanks in advance!

Asia Rudenko JetBrains 124 posts since
2010-11-11
Currently Being Moderated
2012-3-30 下午6:20 in response to: Leonid Shirmanov
Re: Can't get RemoteAgent running as Windows Service

Leonid, hi again. Unfotunately this feature isn't available in 5.0 - we planned to implement it but actually didn't. So remote agent can be run as regular application or as ASP.NET service.

I guess you've read about this feature in our "what's new" blogpost - there was an error, and we're going to correct it now.

Sorry for inconvinience.

More Like This

  • Retrieving data ...