2 Replies Last post: Feb 8, 2013 10:59 PM by Keith Swem  
Keith Swem Newbie 2 posts since
Feb 7, 2013
Currently Being Moderated

Feb 8, 2013 12:09 AM

Problems connecting TeamCity 7.1.3 to SQL Server

Hello TeamCity friends,

 

Our company is trying out TeamCity for CI builds and have installed version 7.1.3 on a Server 2008 R2 machine. So far we've been able to create, configure and build projects using TC and local database, but now we want to connect TC to a SQL db going forward. We've followed the instructions here but have had no luck so far connecting TC to our SQL Server 2008 R2:  http://confluence.jetbrains.com/display/TCD7/Setting+up+an+External+Database#SettingupanExternalDatabase-MicrosoftSQLServer

 

Here are my connection settings when using the JTDS driver:

 

connectionUrl=jdbc:jtds:sqlserver://teamcitysqlserver:1433/TeamCityDb

connectionProperties.user=DOMAIN/user

connectionProperties.password=UniquePassword

connectionProperties.instance=MSSQL

 

And here are my connection settings when using the native JDBC driver:

 

connectionUrl=jdbc:sqlserver://teamcitysqlserver:1433;databaseName=TeamCityDb

connectionProperties.user=DOMAIN/user

connectionProperties.password=UniquePassword

 

However, I keep getting the same error when trying to connect:  SQL query: connect SQL exception: Login failed for user

 

Both the SQL server and TeamCity server are on the same domain; and the DOMAIN/user account we're using to connect to SQL is the accout we're using to run the TeamCity service and is also the SQL admin & dbo. Also, I have SQL configured with mixed authentication mode (both Windows and SQL authentication)

 

Is there something wrong with my database.properties file settings?  What could be the issue?

 

Thanks,

Keith

Leonid Bushuev JetBrains 178 posts since
Sep 30, 2002
Currently Being Moderated
Feb 8, 2013 6:26 PM in response to: Keith Swem
Re: Problems connecting TeamCity 7.1.3 to SQL Server

Hello Keith,

 

I've got two suggestions in this case, try one of:

 

1. Try to remove the DOMAIN/ from the connection properties

 

2. Try to use integrated secirity

 

Best regards!

More Like This

  • Retrieving data ...