2 Replies Last post: Mar 14, 2013 4:07 PM by Andrés Cirugeda  
Andrés Cirugeda Newbie 2 posts since
Nov 26, 2002
Currently Being Moderated

Mar 14, 2013 4:47 AM

Remote SDK, RVM, gems installed with github option are not detected

Hi.

 

I have setup a new Rails edge project in a vagrant box. I'm using RVM in the box to install a 2.0.0 ruby without a specific gemset (just using global). This are the contents of my Gemfile, nothing fancy, just the initial gems.

 

source 'https://rubygems.org'

gem 'rails',     github: 'rails/rails'
gem 'arel',      github: 'rails/arel'
gem 'activerecord-deprecated_finders', github: 'rails/activerecord-deprecated_finders'

gem 'rails-api', github: 'rails-api/rails-api'

gem 'pg'

# To use ActiveModel has_secure_password
# gem 'bcrypt-ruby', '~> 3.0.0'

# To use Jbuilder templates for JSON
# gem 'jbuilder'

# Use unicorn as the app server
gem 'unicorn'

# Deploy with Capistrano
# gem 'capistrano', :group => :development

# To use debugger
# gem 'ruby-debug19', :require => 'ruby-debug'

 

 

When I set the remote SDK, gems installed with the github option are not detected.

 

The only difference I can see is the path where they are installed. Packaged gems are installed in

 

/usr/local/rvm/gems/ruby-2.0.0-p0@global/gems/

 

and the github ones in

 

/usr/local/rvm/gems/ruby-2.0.0-p0@global/bundler/gems/

 

I'm using RubyMine 5.0.2. Is this supported?

 

Regards

Andrés

Oleg Sukhodolsky JetBrains 844 posts since
Apr 4, 2012
Currently Being Moderated
Mar 14, 2013 8:34 AM in response to: Andrés Cirugeda
Re: Remote SDK, RVM, gems installed with github option are not detected

Hi,

 

this is a known problem - http://youtrack.jetbrains.com/issue/RUBY-13069

The fix should be available in next RM's release.

 

Regards, Oleg.

More Like This

  • Retrieving data ...