2 Replies Last post: May 16, 2013 7:05 PM by bokkie  
bokkie Newbie 14 posts since
Jan 30, 2011
Currently Being Moderated

May 14, 2013 8:10 PM

RS8 beta. Odd intellisense completion.

Team, I've been running the latest beta of 8 and unfortunately I had to uninstall it and carry on with version 7. I should add that 7 is fine.

 

The problem I had with 8 is that the intellisense was acting strangely. For example, if I started adding an "if" statement 8 would sometimes change it to something else other than "if", for example, it would add something like IDisposable even though "if" is what I was typing at the time. If I was typing an argument list to a method, the intellisense would add something like this (assume there's a variable called fred):

 

whatever, whatever, ""fred, whatever... Note the ""fred as that's what I was observing.

 

I wish I could explain it more simply but it was a problem that came and went sometimes in the same VS2012 session. I'd like to think that maybe there's a setting that causes this odd behavior but I can't think of anything. It's not that I couldn't use the 8 beta but the loss of intellisense's sanity was really unusual. If somebody has an idea if I've caused the problem i'd be happy to try it again. Unfortunately, screenshots are tricky as the problem comes and goes at different times. I'm mid-stream in an important development phase so I have to stick with 7 as I can't give the time to play with 8. I had to uninstall it which was fine and like I say, 7 is running well.

 

I'm open to suggestions.

Alex Berezoutsky JetBrains 581 posts since
Feb 18, 2011
Currently Being Moderated
May 16, 2013 5:18 PM in response to: bokkie
Re: RS8 beta. Odd intellisense completion.

Hi Peter,

 

Thanks for the report, however we need a consistent repor case in order to reproduce and fix this IntelliSense issue. Could you please create and attach here a small sample with repor steps for it, which will demonstrate us this behavior? Thanks in advance!

More Like This

  • Retrieving data ...