This Question is Possibly Answered

1 "correct" answer available (4 pts) 2 "helpful" answers available (2 pts)
9 Replies Last post: Jun 25, 2013 3:01 PM by Kevin Qu  
David Martin Newbie 6 posts since
Mar 13, 2010
Currently Being Moderated

May 19, 2013 6:36 PM

Odd Analysis Display

Using the ReSharper 7.1.3.2254 on VS2012 U2 on Win8.  I have noticed that every solution I open and every file in that solution that I open exhibit some odd display graphics for the analysis.  The solution wide analysis glyph will display as though it is currently analyzing but in fact it is frozen and will stay in that state indefinitely.  If I open the Errors in Solution window, the same glyhp there is accurate.

 

When I open individual files the right hand gutter also shows a state indicating it is currently analyzing, but it is frozen.  It will show no warnings or  errors as green, yellow, or red ticks marks down the bar.  I have noticed that if I open a file and observe this behavior I can close the file and reopen and it will appear to work.  However, it is not "live" in that I can type obvious errors and the gutter bar does not update to indicate this.  I must close and reopen the file twice more before the error is shown.

 

I have tried to reinstall and repair ReSharper but it did not help.  I have used resharper on many different machines and have never observed this behavior so I'm inclined to think there is something else installed or going on here - I just have no idea where to begin looking for a solution.

 

Again, the Errors in Solution window works perfectly and in real time.  I have tried changing the VS themes thinking they might conflict, but no help.

 

Anny help getting this working again would be greatly appreciated.

SolutionWide.JPGFileAnalysis.JPG

Kevin Qu Newbie 4 posts since
Jun 5, 2013
Currently Being Moderated
Jun 5, 2013 10:18 AM in response to: David Martin
Re: Odd Analysis Display

I have met the same issue on ReSharper 7.1.2000.1478 on VS 2010 on win7. Anyone who can give some help?

Frane Crnjak Newbie 73 posts since
Sep 11, 2011
Currently Being Moderated
Jun 5, 2013 12:40 PM in response to: Kevin Qu
Re: Odd Analysis Display

Try installing R#8 EAP http://confluence.jetbrains.com/display/ReSharper/ReSharper+8+EAP

 

Then open few solutions and see does code analysis works perfectly. If does then uninstall R#8 EAP and install back R#7.

 

I had some similar problem http://devnet.jetbrains.com/thread/441237  but I can't remember exactly how did I solve it, and I think it was by installing some other version of R# then installing back my current one

 

I hope this helps

Kevin Qu Newbie 4 posts since
Jun 5, 2013
Currently Being Moderated
Jun 5, 2013 2:29 PM in response to: Frane Crnjak
Re: Odd Analysis Display

Hi Frane,

 

Thanks for your reply but it did not work for me.

 

I think we do not face the same issue. When I hover over the marker bar it will show some tips like "6 warings, 1 error", but the icon and red, yellow and green bars are not shown properly. I think the code analysis works well but there is something wrong when it renders the marker bar.

Untitled.png

 

Any other advices?

 

Thanks

Frane Crnjak Newbie 73 posts since
Sep 11, 2011
Currently Being Moderated
Jun 5, 2013 2:44 PM in response to: Kevin Qu
Re: Odd Analysis Display

hmm you have that problem with all solutions or with some/few solutions?

 

Try deleting R# cache?

Kevin Qu Newbie 4 posts since
Jun 5, 2013
Currently Being Moderated
Jun 5, 2013 4:01 PM in response to: Frane Crnjak
Re: Odd Analysis Display

I've tried deleting cache automatically and manually, but it did not work.

 

I have the problem with all solutions.

 

BTW: The problem first appeared when I imported a VS settings file. After that I reset my VS settings to default but the problem did not disappear.

 

Message was edited by: Kevin Qu

Alex Berezoutsky JetBrains 580 posts since
Feb 18, 2011
Currently Being Moderated
Jun 19, 2013 1:44 PM in response to: David Martin
Re: Odd Analysis Display

Hi David (and others),

 

We've fixed this issue in the most recent ReSharper 8 EAP build: http://confluence.jetbrains.com/display/ReSharper/ReSharper+8+EAP

Could you please check it out and let me know if it's fixed for you or not?

 

If not, we would appreciate a sample solution, which will demonstrate this issue.
Thanks!

Kevin Qu Newbie 4 posts since
Jun 5, 2013
Currently Being Moderated
Jun 25, 2013 3:01 PM in response to: Alex Berezoutsky
Re: Odd Analysis Display

Thanks a lot, Alex.The new build fixed the issue in my environment.

More Like This

  • Retrieving data ...