2 Replies Last post: Jun 23, 2013 5:17 PM by Jerry Mee  
Jerry Mee Newbie 2 posts since
Jun 23, 2013
Currently Being Moderated

Jun 23, 2013 2:49 PM

Can't type left curly bracket

Hi, I'm new here and I had downloaded a phpStorm as trial version. I think it's very good IDE but if I create a new project for example, I can't type left curly bracket { and I don't really know why while in another IDE (NetBeans) or just in notepad works everything fine. The same problem is with sign of greater-than >. If I try type sign > I get message "There are no custom folding regions in the current file". I'm using Windows 7 so I would like to ask where is problem. Thanks for reply.

Andriy Bazanov Master 3,991 posts since
May 28, 2010
Currently Being Moderated
Jun 23, 2013 4:25 PM in response to: Jerry Mee
Re: Can't type left curly bracket

Hi there,

If I try type sign > I get message "There are no custom folding regions in the current file"

Seems to me that there is some problem with keyboard or keyboard layout ... because default shortcut for "Custom folding region" is Ctrl+. ... and you trying to press Shift+. (to enter > symbol)

 

What is your keyboard layout / language in Windows ? Try setting it to "US English" (or whatever English is better suited for you there).

 

I know that there are some problems on some keyboard layouts (e.g. it's problematic to enter to enter Ctrl+/ on German layout) .. but have not heard anything about problems with { or >

 

 

In any case:

  1. "Settings | Keymap"
  2. Make your own keymap (a copy of pre-defined one) -- this will allow you to modify it (as any pre-defined is fixed and cannot be modified)
  3. Search for actions that may have any shortcuts assigned to any keys with those characters (there is "search by key" functionality -- a button next to the "bin" icon on the top right, next to input box) and re-assign then another (different) shortcut.

More Like This

  • Retrieving data ...