This Question is Possibly Answered

1 "correct" answer available (4 pts) 2 "helpful" answers available (2 pts)
3 Replies Last post: Jul 2, 2013 4:08 PM by Elena Pogorelova  
Simple Simon Newbie 2 posts since
Jul 1, 2013
Currently Being Moderated

Jul 1, 2013 5:48 AM

How to get IDE support extension to work with chrome?

I have exhausted all options to try to get this to work.  If anyone can offer suggestions of what I should be doing, I would greatly appreciate it.

 

I installed WebStorm and the extension.  I have not found instructions for additional setup requirements, so have not done anything else.

 

I am using:

Windows 8 x64

WebStorm 6.0.2

Chrome  27.0.1453.116 m

JetBrains IDE Support Chrome extension 1.10

 

  • When I debug/run, chrome starts, but only on the default page.  It never loads my app.
  • WebStorm pops the following message: "Waiting for connection from JetBrains IDE Support extension for Chrome.  Please ensure you have installed the extension or see Help.
  • The WebStorm console displays: "10:40:48 AM JetBrains IDE Support extension for Chrome: Please ensure that JetBrains IDE Support extension is installed and enabled in Google Chrome."
  • If I inspect the _generated_background_page.html console, there is no output.
  • chrome_debug.log provides the following output.

[9844:4984:0701/114331:VERBOSE1:client_socket_pool_base.cc(65)] Setting g_socket_reuse_policy_penalty_exponent = -1

[9844:4984:0701/114331:VERBOSE1:pref_proxy_config_tracker_impl.cc(145)] 02B3AC60: set chrome proxy config service to 02B3AA20

[9844:4984:0701/114331:VERBOSE1:pref_proxy_config_tracker_impl.cc(235)] 02B3AC60: Done pushing proxy to UpdateProxyConfig

[9844:4984:0701/114331:VERBOSE1:pref_proxy_config_tracker_impl.cc(145)] 02B3AC60: set chrome proxy config service to 00000000

Any suggestions would be greatly appreciated.
Elena Pogorelova Apprentice 996 posts since
Oct 5, 2011
Currently Being Moderated
Jul 1, 2013 4:33 PM in response to: Simple Simon
Re: How to get IDE support extension to work with chrome?

Hello!

 

may be a port issue. Please, can you attach your idea.log?

 

 

Best regards,

Lena

Elena Pogorelova Apprentice 996 posts since
Oct 5, 2011
Currently Being Moderated
Jul 2, 2013 4:08 PM in response to: Simple Simon
Re: How to get IDE support extension to work with chrome?

Hi Simon,

 

thanks for details.

 

WebStorm is trying to open the default port (63342) on startup; if it fails, the next 20 are tried... If all them fail (because of a firewall, anti-virus software, etc.), then the first  free port is occupied - 19705 in your case. The solution here is to use 19705 explicitly instead of the default one  (add -Drpc.port=19705 to bin/WebStorm.exe.vmoptions and configure chrome  extension to use this port)

 

 

Best regards,

Lena

More Like This

  • Retrieving data ...