This Question is Possibly Answered

1 "correct" answer available (4 pts) 2 "helpful" answers available (2 pts)
10 Replies Last post: Jul 23, 2013 4:36 PM by Michael Kuzmin  
Dave Watkins Newbie 6 posts since
Jul 12, 2013
Currently Being Moderated

Jul 12, 2013 7:55 PM

TFS builds not working after the upgrade to 8.0 (build 27402)

We upgraded our installation yesterday and noticed that all builds using TFS are hanging at the "Checking for changes" step.  The builds never seem to error out or stop. They just display a red box with the message "Failed to start build #35524 on SERVER NAME" and when you click on details » the message says "Cannot start build runner".  If I go in to Edit the Configuration and test the source control connection, the graphic just spins and never resolves. (see attatched). All of these builds worked before the upgrade.

 

Any ideas?image003.png

Michael Kuzmin JetBrains 1,554 posts since
Jul 30, 2005
Currently Being Moderated
Jul 15, 2013 4:35 PM in response to: Dave Watkins
Re: TFS builds not working after the upgrade to 8.0 (build 27402)

Dave,

 

Could you please send us teamcity-server.log and teamcity-vcs.log files.

You can attach them here, or send privately to teamcity-feedback@jetbrains.com. In last case please add a reference to this thread to the message.

 

Thanks

Eugene Petrenko JetBrains 2,377 posts since
Oct 4, 2004
Currently Being Moderated
Jul 16, 2013 7:31 PM in response to: Dave Watkins
Re: TFS builds not working after the upgrade to 8.0 (build 27402)

Hello,

 

Thanks for logs. Could you please provide server thread dumps as well. To capture thread dumps open Administraction | Diagnostings and click "Save Thread Dump" several times

 

I saw a number of DB connection exceptions on the server.

Please consider restaring it after you captured thread dumps.

Eugene Petrenko JetBrains 2,377 posts since
Oct 4, 2004
Currently Being Moderated
Jul 16, 2013 9:49 PM in response to: Dave Watkins
Re: TFS builds not working after the upgrade to 8.0 (build 27402)

Thanks for dumps.

There are unexpectedly many OSProcessHandler pooled threads there.

I analyze those dumps and let you know the results

Eugene Petrenko JetBrains 2,377 posts since
Oct 4, 2004
Currently Being Moderated
Jul 20, 2013 12:15 AM in response to: Dave Watkins
Re: TFS builds not working after the upgrade to 8.0 (build 27402)

Just to continue the thread:

 

Discussion held via e-mail and ended up with http://youtrack.jetbrains.com/issue/TW-30698

Michael Kuzmin JetBrains 1,554 posts since
Jul 30, 2005
Currently Being Moderated
Jul 23, 2013 4:36 PM in response to: Dave Watkins
Re: TFS builds not working after the upgrade to 8.0 (build 27402)

We have released version 8.0.2 where this issue has been fixed.

More Like This

  • Retrieving data ...