1 Replies Last post: Jul 16, 2013 7:48 PM by Julia Reshetnikova  
Marty Phee Newbie 8 posts since
Nov 26, 2008
Currently Being Moderated

Jul 16, 2013 12:26 AM

Issues with Agent Cloud

We're running 7.1.5

 

I was playing around with elastic agents.  I was able to create an agent instance and it worked fine with Teamcity.  I then turned on agent cloud and there's where I have trouble.

 

It starts the instances without issue, but can't communicate with them.  Looks like it thinks the agent is actually at localhost:9090.  I updated the properties so name, server and token are commented out.

 

 

[2013-07-15 19:40:08,759]   INFO -    jetbrains.buildServer.AGENT - New agent authorization token "1ac4b6aeee34695f7fcebe55d56c6b63" was generated for agent "EC2-i-3844f753" (127.0.0.1:9090)

[2013-07-15 19:40:08,780]   INFO - tbrains.buildServer.ACTIVITIES - Agent "EC2-i-3844f753" was authorised with comment "Locally installed agent is authorized by default"

[2013-07-15 19:40:08,923]   INFO -   jetbrains.buildServer.SERVER - Agent has been registered: EC2-i-3844f753 {id=4, host=127.0.0.1:9090, agentTypeId=4, pool=Default}, not running a build

[2013-07-15 19:40:09,348]   INFO -   jetbrains.buildServer.SERVER - Agent EC2-i-3844f753 {id=4, host=127.0.0.1:9090, agentTypeId=4, pool=Default} has been unregistered. Reason: Cannot access agent

[2013-07-15 19:40:14,281]   INFO - tbrains.buildServer.ACTIVITIES - Agent "EC2-i-3844f753" was enabled

[2013-07-15 19:42:41,989]   INFO -   jetbrains.buildServer.SERVER - Agent description updated for agent: Default Agent {id=1, host=127.0.0.1:9090, agentTypeId=1, pool=Default}

[2013-07-15 19:43:09,233]   INFO -   jetbrains.buildServer.SERVER - Agent has been registered: EC2-i-3844f753 {id=4, host=127.0.0.1:9090, agentTypeId=4, pool=Default}, not running a build

[2013-07-15 19:43:13,942]   INFO -   jetbrains.buildServer.SERVER - Agent EC2-i-3844f753 {id=4, host=127.0.0.1:9090, agentTypeId=4, pool=Default} has been unregistered. Reason: Cannot access agent

[2013-07-15 19:46:11,259]   INFO -   jetbrains.buildServer.SERVER - Agent has been registered: EC2-i-3844f753 {id=4, host=127.0.0.1:9090, agentTypeId=4, pool=Default}, not running a build

[2013-07-15 19:46:14,927]   INFO - tbrains.buildServer.ACTIVITIES - Build started; name=OpenEnglish :: OpenEnglish QA Build, personal=false, buildId=4594

[2013-07-15 19:46:14,965]   INFO - tbrains.buildServer.ACTIVITIES - Configuration removed from queue; name=OpenEnglish :: OpenEnglish QA Build, requestor=Marty Phee, comment=null, user=null, promotion id=4762

[2013-07-15 19:46:14,965]   INFO -   jetbrains.buildServer.SERVER - Flush queue finished, number of builds started: 1

[2013-07-15 19:46:15,618]   WARN -   jetbrains.buildServer.SERVER - jetbrains.buildServer.serverSide.ExecutionException: Call http://127.0.0.1:9090/RPC2 buildAgent.runBuild: org.apache.xmlrpc.XmlRpcException: java.lang.Exception: jetbrains.buildServer.AlreadyRunningBuildException: Already running a build 4593 true

[2013-07-15 19:46:15,659]   INFO -   jetbrains.buildServer.SERVER - Running build bt10 on EC2-i-3844f753, build id: 4594 was interrupted: FINISHED_UNEXPECTEDLY [comment: Agent EC2-i-3844f753 unregistered: Runs unknown build we're not aware of, user:null]

[2013-07-15 19:46:15,676]   INFO - ity.BuildQueuePriorityOrdering - New item QueuedBuildImpl{myBuildType=OpenEnglish :: OpenEnglish QA Build {id=bt10},ItemId=4764} with weight 0.00 inserted at the default position 0 in the end of the queue

[2013-07-15 19:46:15,757]   INFO - tbrains.buildServer.ACTIVITIES - Build BUILD_PROMOTION{id=4764} was added to queue by "Marty Phee"

[

Julia Reshetnikova JetBrains 3 posts since
Jun 17, 2013
Currently Being Moderated
Jul 16, 2013 7:48 PM in response to: Marty Phee
Re: Issues with Agent Cloud

Hi Marty,

 

If you are running a reverse proxy in front of your TeamCity server then it will report the proxy's IP address instead of the agent's. When the proxy server sits in the same machine the reported ip address could be 127.0.0.1.

Could you please check the last case described in Set Up TeamCity behind a proxying server section of the How To and see if it helps?

If this is not your case, could you please provide build agent logs and agent properties file?

 

Thanks!

More Like This

  • Retrieving data ...