1 Replies Last post: Aug 3, 2013 8:35 AM by Oleg Sukhodolsky  
James Bond Newbie 6 posts since
Jan 21, 2013
Currently Being Moderated

Jul 30, 2013 1:57 AM

"Run configuration Error"   only in one specific project

Hello,

 

I am on latest version on OSX and latest version of RubyMine and versions of my Ruby and Rails are also 2.0 and 4.0 or 420 if you like it that way

 

If I do a File->New->Rails App .... and run the app from inside IDE by clicking on that Play button it works fine. No issues.

 

If I run the older version of my GitHub taken app that was using Rails 3.2.14 that one also works fine, No issues.

 

But the newer version of the app above is on Ruby 2.0 Rails 4.0 ... so if I checkout a fresh copy of it from GitHub and want to run it the same way I get the nasty error of

 

        Error running Development: smart_registries:
Rails 2.x launcher script      was found instead of Rails 4.x one. You need      '/Users/JamesBond/his_poor_app/bin/rails' script to launch Rails      server. Please update server launcher according to Rails 4.x documentation
    

 

 

even as as soon as I go to Run -> Edit Config menu and open the dialog it is showing me that error at the buttom of the page.

 

No clue what to do or where does it come from.  Please let me khow what other info I need to post so it helps out solving this problem.

 

Thanks.

Oleg Sukhodolsky JetBrains 871 posts since
Apr 4, 2012
Currently Being Moderated
Aug 3, 2013 8:35 AM in response to: James Bond
Re: "Run configuration Error"   only in one specific project

Hi James,

 

could you please provide link to the problematic project so I could try to run it and see what's wrong with it.

 

Thanks, Oleg.

More Like This

  • Retrieving data ...