This Question is Answered

16 Replies Last post: Sep 27, 2013 11:20 PM by Nikos Dimitrakopoulos  
Nick Black Newbie 7 posts since
Sep 10, 2013
Currently Being Moderated

Sep 10, 2013 1:40 PM

Errors in rubymine console running cucumber tests after updating to latest rvm / ruby

I just updated rvm and ruby to the latest stable version (2.0.0p247).

 

When I run cucumber tests in rubymine 5.4 I see the following messages in the output console. I didn't see the "sh: __rvm_date" messages before the update.

 

Anyone have any ideas what's going on here?

 

I think it's related to the teamcity stuff as I don't see these messages when I run from the command line. We're not using teamcity so it would be great to be able to turn off that formatting- does anyone know a way to do that?

 

Thanks,

Nick

 

 

 

##teamcity[testSuiteStarted name = 'Scenario: BlahBlah' locationHint = 'file:///Blah.feature:4' timestamp = '2013-09-10T10:07:12.503+0100']

 

##teamcity[customProgressStatus type = 'testStarted' timestamp = '2013-09-10T10:07:12.503+0100']

sh: __rvm_date: line 1: syntax error: unexpected end of file

sh: error importing function definition for `__rvm_date'

sh: __rvm_date: line 1: syntax error: unexpected end of file

sh: error importing function definition for `__rvm_date'

sh: __rvm_date: line 1: syntax error: unexpected end of file

sh: error importing function definition for `__rvm_date'

sh: __rvm_date: line 1: syntax error: unexpected end of file

sh: error importing function definition for `__rvm_date'

sh: __rvm_date: line 1: syntax error: unexpected end of file

sh: error importing function definition for `__rvm_date'

sh: __rvm_date: line 1: syntax error: unexpected end of file

sh: error importing function definition for `__rvm_date'

 

sh: __rvm_date: line 1: syntax error: unexpected end of file

### Starting on simulator

Oleg Sukhodolsky JetBrains 822 posts since
Apr 4, 2012

I'd say that you either have some problem with rvm's installation or you need to restart RM to get updated version of rvm in its shell.

 

Let me know if this help.

 

Regards, Oleg.

Oleg Sukhodolsky JetBrains 822 posts since
Apr 4, 2012

I've just updated rvm to the latest stable (1.22.6) and tried to run cucumber test from RM 5.4.3.2.1 and everything works fine on my Linux

 

What exact version of RM are you using? What os? How are you executing cucumber (run one file, all features in folder, or  rake task)?

Also does the problem reproducible for any project?  Could you please provide test project which demonstrates the problem.

 

Regards, Oleg.

Oleg Sukhodolsky JetBrains 822 posts since
Apr 4, 2012

I will try to reproduce the problem on Mac tomorrow.

Oleg Sukhodolsky JetBrains 822 posts since
Apr 4, 2012

We have tried this today on Mac (with one of our cucumber project) and everything works fine.

The project you have pointed out is not a ruby project thus we were unable to use it

If you have some ruby project which reproduce the problem please provide it.

 

Regards, Oleg.

Teresa Peters Newbie 4 posts since
Sep 12, 2013

Nick, I have the same issue and setup.  I got past this issue by typing this onto the terminal window: rvm reinstall ruby-2.0.0-p247.

Oleg Sukhodolsky JetBrains 822 posts since
Apr 4, 2012

Thank you for information.  Hope this will help to Nick.

 

Regards, Oleg.

Oleg Sukhodolsky JetBrains 822 posts since
Apr 4, 2012

Hi,

 

here is a simple project with cucumber features.

 

Oleg.

Attachments:
Oleg Sukhodolsky JetBrains 822 posts since
Apr 4, 2012

It might be our formatter which calls something but w/o reproducible test I cannot help you

 

Oleg.

Teresa Peters Newbie 4 posts since
Sep 12, 2013

Today the errors came back for some reason so we are in the same boat again.  Think this might be relevant?: http://developer.appcelerator.com/question/157074/cant-get-titanium-up-and-running-for-android.  I am going to roll back my version as well.

Nikos  Dimitrakopoulos Newbie 5 posts since
Feb 18, 2011

I'm also having this problem with the following rvm setup:

 

  system:

    uname:       "Darwin klee.lan 12.4.0 Darwin Kernel Version 12.4.0: Wed May  1 17:57:12 PDT 2013; root:xnu-2050.24.15~1/RELEASE_X86_64 x86_64"

    system:      "osx/10.8/x86_64"

    bash:        "/usr/local/bin/bash => GNU bash, version 4.2.42(2)-release (i386-apple-darwin12.2.0)"

    zsh:         "/bin/zsh => zsh 4.3.11 (i386-apple-darwin12.0)"

 

  rvm:

    version:      "rvm 1.22.13 (latest) by Wayne E. Seguin, Michal Papis [https://rvm.io/]"

    updated:      "3 seconds ago"

    path:         "/Users/nikosd/.rvm"

 

  ruby:

    interpreter:  "ruby"

    version:      "1.9.3p392"

    date:         "2013-02-22"

    platform:     "x86_64-darwin12.2.0"

    patchlevel:   "2013-02-22 revision 39386"

    full_version: "ruby 1.9.3p392 (2013-02-22 revision 39386) [x86_64-darwin12.2.0]"

More Like This

  • Retrieving data ...