This Question is Answered

1 "correct" answer available (4 pts) 2 "helpful" answers available (2 pts)
1 Replies Last post: Sep 12, 2013 9:36 PM by Teresa Peters  
Teresa Peters Newbie 4 posts since
Sep 12, 2013
Currently Being Moderated

Sep 12, 2013 9:10 PM

"Error running <test name>: Cucumber Gem isn't installed for RVM: ruby-2.0.0-p247 [global]

For some background info, I installed Cucumber by installing Calabash.  I have also cross-posted on both forums: here and here

 

My team was using the default version of Ruby on Mac OSX which  is 1.8.  I decided to be the team guinea pig for updating to 2.0 yesterday and ran into a blocking issue.

I did the following:
  1. Installed Homebrew: ruby -e "$(curl -fsSL https://raw.github.com/mxcl/homebrew/go)"
  2. Installed RVM: \curl -L https://get.rvm.io | bash -s stable --ruby
  3. Ran through the instructions here: http://architects.dzone.com/articles/upgrading-ruby-20-mountain
  4. Opened the RubyMine settings
    • [Settings Dialog] Changeed the Ruby SDK and Gems settings to use the new ruby version (Under Ruby SDK)
    • [Settings Dialog] Selected Update Gems
    • [Update Gems Dialog] Selected any items that need updating and then press the Update button

After that, RubyMine no longer plays nice and I get this error message: Error running Smoke Test: Cucumber Gem isn't installed for RVM: ruby-2.0.0-p247 [global] SDK

 

Anyone  else use this setup that might have an idea what caused the issue and  how to fix it?  I'm not very familiar or comfortable with the concept of Gems yet.  We don't have any custom gem files.  I just want to be able to use Ruby 2.0 inside RubyMine so I can update our Calabash code to use the new syntax, and because Cucumber will soon be moving away from 1.8 support.  I wasn't able to find any information on this issue within the RubyMine help docs or doing a search online.

 

Thanks,

          Teresa

More Like This

  • Retrieving data ...