10 Replies Last post: Oct 4, 2013 1:21 PM by saeedeh a  
saeedeh a Newbie 6 posts since
Oct 3, 2013
Currently Being Moderated

Oct 3, 2013 9:53 AM

changing url to localhost

i installed phpstorm and write a html program but each time run it this address "file:///C:/Users/Saeedeh/PhpstormProjects/it/it.html" is shown. how can i change it to localhost.

Andriy Bazanov Master 3,641 posts since
May 28, 2010
Currently Being Moderated
Oct 3, 2013 12:50 PM in response to: saeedeh a
Re: changing url to localhost

Hi there,

 

You have to configure and mark as default a deployment entry at "Settings | Deployment"

 

P.S.

What PhpStorm version do you use?

Andriy Bazanov Master 3,641 posts since
May 28, 2010
Currently Being Moderated
Oct 3, 2013 7:54 PM in response to: saeedeh a
Re: changing url to localhost

Don't know ...

 

Do you have any local web server installed (for example: Apache/IIS)? Is it configured correctly?

Andriy Bazanov Master 3,641 posts since
May 28, 2010
Currently Being Moderated
Oct 3, 2013 9:21 PM in response to: saeedeh a
Re: changing url to localhost
Andriy Bazanov Master 3,641 posts since
May 28, 2010
Currently Being Moderated
Oct 4, 2013 12:51 PM in response to: saeedeh a
Re: changing url to localhost

That message means that browser is having problem with contacting your web server (most likely, since it's network related).

 

1) What URL is requested?

2) Does it work if you type URL manually in the browser?

3) Please try 127.0.0.1 instead of localhost -- will it help?

Andriy Bazanov Master 3,641 posts since
May 28, 2010
Currently Being Moderated
Oct 4, 2013 1:12 PM in response to: saeedeh a
Re: changing url to localhost
it dident copy automatically to htdocs.

What do you have at "Settings | Deployment | Options --> Upload changed files automatically to the default server" ? Quite likely you have fortgot to enable it (value should be other than "Never")

More Like This

  • Retrieving data ...