This Question is Not Answered

1 "correct" answer available (4 pts) 2 "helpful" answers available (2 pts)
4 Replies Last post: Oct 15, 2013 9:49 PM by Raj S  
Raj S Newbie 3 posts since
Oct 15, 2013
Currently Being Moderated

Oct 15, 2013 7:13 PM

Build fails after upgrading to Appcode 2.5 (still builds in xcode)

Hi,

 

After upgrading to appcode 2.5, I can no longer get my app to build (However it still builds fine in xcode). The build log shows that it's not able to find several common libraries.

 

"ld: in '/Developer/SDKs/MacOSX10.5.sdk/usr/lib/libobjc.A.dylib', missing required architecture armv7 in file /Developer/SDKs/MacOSX10.5.sdk/usr/lib/libobjc.A.dylib (4 slices) for architecture armv7

clang: error: linker command failed with exit code 1 (use -v to see invocation)"

 

It seems like it is not looking in the right place for the libs (or just using the wrong version/type). Is there some project setting that I need to update?

 

- I have verfied the xcode version in Appcode->Preferences

- Done a clean and a clean build folder

- Made sure I have the latest xcode

 

Thanks

Dmitry Semeniouta Novice 75 posts since
Dec 17, 2012
Currently Being Moderated
Oct 15, 2013 9:14 PM in response to: Raj S
Re: Build fails after upgrading to Appcode 2.5 (still builds in xcode)

Looks like OS X SDK is used to build iOS project. Please check "Base SDK" and "Architectures" settings of your project both in Xcode and AppCode and tell us if their values differ.

Dmitry Semeniouta Novice 75 posts since
Dec 17, 2012
Currently Being Moderated
Oct 15, 2013 9:29 PM in response to: Raj S
Re: Build fails after upgrading to Appcode 2.5 (still builds in xcode)

Looks OK so far. May I ask you to send us .xcodeproj folder from your project to appcode-support@jetbrains.com? It will be much faster this way.

More Like This

  • Retrieving data ...