This Question is Answered

1 "correct" answer available (4 pts) 1 "helpful" answer available (2 pts)
12 Replies Last post: Oct 23, 2013 12:32 PM by Ruslan Konyshev  
Ruslan Konyshev Newbie 11 posts since
Oct 3, 2012
Currently Being Moderated

Oct 16, 2013 12:45 PM

AppCode 2.5 code sign issue?

In my iOS project I have 2 separate targets for iPad and iPhone. Also I have another OSX target in project, this is my so-called build tools( I use it to choose appropriate resources, convert this resources if needed, and copy this resources in derived data for my iOS products during the build phase). iOS targets, of course has this build tools in their "Target Dependencies", so this OSX target compiles every time i compile iOS target. The problem is that every time I try to use compiled with Appcode version of my build tools I get "Killed: 9" in console. As I understand it could be a signing problem, but in XCode all works fine. Also I've tried to compile just my build tools and use it from terminal, but with the same result. Code sign identity for my build tools is set to "Don't code sign", for iOS targets code sign identity set to "iOS Developer".

Dmitry Semeniouta Newbie 72 posts since
Dec 17, 2012
Currently Being Moderated
Oct 16, 2013 3:21 PM in response to: Ruslan Konyshev
Re: AppCode 2.5 code sign issue?

Please send us a log file of the clean build. You can open it in Console.app

 

log.png

 

and then reveal it in Finder

 

log2.png

 

Thanks

Dmitry Semeniouta Newbie 72 posts since
Dec 17, 2012
Currently Being Moderated
Oct 16, 2013 6:51 PM in response to: Ruslan Konyshev
Re: AppCode 2.5 code sign issue?

Looks like the problem arise from PBTexturePackerScript.sh at line 183. Could you please check what's the difference between Xcode and AppCode runs? You can use 'set -v; set -x' inside script to log script commands as they are executing.

Anton Makeev JetBrains 1,247 posts since
Dec 19, 2006
Currently Being Moderated
Oct 18, 2013 11:52 AM in response to: Ruslan Konyshev
Re: AppCode 2.5 code sign issue?

Ruslan,

could you please clarify: are you getting errors in AppCode during build, or only then you launch the application?

If it is the former, please attach the build log from Xcode as well. If it is the latter, does Xcode launch the product for the same target correctly?

Does the problem stay even after cleaning build folder? (Xcode: hold Alt in Product menu and select Clean Build Folder, AppCode: click Clean Build Folder in Run menu)

Dmitry Semeniouta Newbie 72 posts since
Dec 17, 2012
Currently Being Moderated
Oct 22, 2013 6:25 PM in response to: Ruslan Konyshev
Re: AppCode 2.5 code sign issue?

OK, I've managed to reproduce this with AppCode using Xcode 5 (5A1413). But I was able to build and run just fine on toolchain of Xcode 5.0.1 GM (5A2034a).

What Xcode version do you have at `xcode-select --print-path`?

Anton Makeev JetBrains 1,247 posts since
Dec 19, 2006
Currently Being Moderated
Oct 23, 2013 12:16 PM in response to: Ruslan Konyshev
Re: AppCode 2.5 code sign issue?

Ruslan,

if updating to Xcode 5.0.1 doesn't help, please try this build and check if it works or not.

More Like This

  • Retrieving data ...