This Question is Answered

2 "helpful" answers available (2 pts)
2 Replies Last post: Oct 17, 2013 6:41 PM by Joe Coder  
Joe Coder Newbie 9 posts since
Aug 21, 2013
Currently Being Moderated

Oct 17, 2013 10:03 AM

AppCode 2.5 loses availability of LLDB until OS X upgrade?

I recently "upgraded" from the previous version of AppCode, to the latest version 2.5

Generally, when one thinks of an Upgrade, they probably consider one definition of that to mean "you get everything you had before, and then some"

 

I noticed in the debugger that it was set to GDB, and when I tried to change it to LLDB, it says I have to upgrade to a later OS X.

I have OS X 10.7.5

 

Why do I need a later OS X now in order to use LLDB?

Anton Makeev JetBrains 1,281 posts since
Dec 19, 2006
Currently Being Moderated
Oct 17, 2013 10:53 AM in response to: Joe Coder
Re: Is AppCode 2.5 supposed to be a downgrade?

Joe, it's because the latest LLDB framework is only compatible with OS X 10.8.

GDB functionality on OS X 10.7 is comparable with that of LLDB so you should not miss LLDB much. Anyway, please let us know if you find any issues with it.

 

What are the reasons you don't upgrade to the latest OS X?

More Like This

  • Retrieving data ...