1 Replies Last post: Oct 17, 2013 5:56 PM by Elena Pogorelova  
Demidov Aleksander Newbie 1 posts since
Mar 29, 2012
Currently Being Moderated

Oct 17, 2013 8:32 AM

Autocomplete insertion double quotes after start typing html tag attribute

Hi.

I can not find option to turn off autocomplete insertion a double qoutes after put symbol "=" after start html tag attributes

 

Example:

 

Im typing:

<div class=

 

Php Storm automatic generate double quotes:

<div class=""

 

Im continuosly typing:

"field"

 

Result:

<div class=""field"

 

In result - three double quotes. It`s wrong!

 

My time to work is dgradate. Im degradate.

 

PS: this autocomplete option - incorrectly worked. some time Php Storm not insertion a that quotes, but some time Php Storm insert that quotes.

 

PS2: Im work with PhpStorm in remote machine (internet connection ADSL and my fps is smallest and remote machine not big power) - may be that is problem for some time incorrectly worked that new feature of PhpStorm - autocompletion (or smart keys) - double qoutes insertion after start html attribute

PS3: Option in "Editr -> Smart keys - Automatically start attribute" no effect

 

PHPStorm EAP 131.332

OS: Linux

Elena Pogorelova Apprentice 1,057 posts since
Oct 5, 2011
Currently Being Moderated
Oct 17, 2013 5:56 PM in response to: Demidov Aleksander
Re: Autocomplete insertion double quotes after start typing html tag attribute

Hello!

 

this feature can't be turned off

 

>In result - three double quotes. It`s wrong!

 

Known bug, please vote for http://youtrack.jetbrains.com/issue/IDEA-113332

More Like This

  • Retrieving data ...