This Question is Not Answered

1 "correct" answer available (4 pts) 2 "helpful" answers available (2 pts)
2 Replies Last post: Oct 27, 2013 7:06 PM by Timo A. Hummel  
Timo A. Hummel Newbie 2 posts since
Oct 27, 2013
Currently Being Moderated

Oct 27, 2013 3:37 PM

How to disable HTML autocompletion in PhpStorm 7.0?

Hi,

 

PhpStorm 7.0 autocompletes quotation marks when typing, which is annoying for me. I also haven't found an obvious location on where to disable that feature. I already have disabled Editor > Smart Keys > Insert Pair Quote, but that did not do the trick. Any clue if that's possible?

 

Thanks

Felicitus

Elena Pogorelova Apprentice 956 posts since
Oct 5, 2011
Currently Being Moderated
Oct 27, 2013 7:04 PM in response to: Timo A. Hummel
Re: How to disable HTML autocompletion in PhpStorm 7.0?

Hello!

 

'Insert pair quote' option doesn't affect HTML attributes autocompletion: PhpStorm  actually auto-inserts both opening and closing quote as soon as you type  '=' in attribute definition, so it doesn't insert a closing quote, it  auto-completes both opening and closing one... There is no way to turn  this auto-completion off.

Why do you need to do this? Please check  http://youtrack.jetbrains.com/issue/IDEA-113332 - is it what you are complaining about?

More Like This

  • Retrieving data ...