7 Replies Last post: Oct 30, 2013 9:31 PM by Nathan Curtis  
Nathan Curtis Newbie 5 posts since
Oct 29, 2013
Currently Being Moderated

Oct 29, 2013 5:49 AM

AIR 3.9 ADL launch fails

I just upgraded (well, I tried this a couple weeks ago too, but was too busy then to try to deal with this problem) to AIR 3.9 from 3.8. Under 3.8, my build/launch configurations all worked just fine. Now in 3.9, I get the "initial content not found" error from ADL. The mysterious thing is that if I immediately copy the adl command from the IntelliJ run box to the command line, it works just fine. This would be OK as a stopgap, except for one thing: I can't debug using this workaround. As far as I can tell, this is new with 3.9. I've used IntelliJ 12 with several versions of AIR 3.8 with no problem.

 

I've done everything I can think of to try to clear this up, anybody else have some suggestions? Is this just straight up a bug that needs to get fixed by IntelliJ? I don't mind submitting a bug report if that's the case, I'm just not sure yet this isn't something I can't fix locally.

Alexander Doroshko JetBrains 1,260 posts since
Jun 9, 2009
Currently Being Moderated
Oct 29, 2013 10:28 AM in response to: Nathan Curtis
Re: AIR 3.9 ADL launch fails

What is your OS?

Please paste adl command line and full error output from IntelliJ IDEA.

So far I have no idea why the command works from command line but doesn't work from IDE...

Alexander Doroshko JetBrains 1,260 posts since
Jun 9, 2009
Currently Being Moderated
Oct 29, 2013 10:53 AM in response to: Nathan Curtis
Re: AIR 3.9 ADL launch fails

Thanks. Though I still can't understand why the same command works differently from Terminal.

One strange thing with your adl command line is that it doesn't contain -XscreenDPI and -XversionPlatform options. Are you sure you use the latest IntelliJ IDEA 12.1.6?

 

There's already an issue about different behavior of adl from IDE and from Terminal, which I can't understand as well: http://youtrack.jetbrains.com/issue/IDEA-114714. But your case is different.

 

Are you using standalone AIR SDK + ASC 2.0 or Flex SDK overlaid with AIR SDK? May I take a look at your *.iml file with Flash module settings?

Alexander Doroshko JetBrains 1,260 posts since
Jun 9, 2009
Currently Being Moderated
Oct 30, 2013 8:06 PM in response to: Nathan Curtis
Re: AIR 3.9 ADL launch fails

Try AIR SDK 3.9.0.1200. A lot of problems go away with this update.

More Like This

  • Retrieving data ...