This Question is Possibly Answered

1 "correct" answer available (4 pts) 2 "helpful" answers available (2 pts)
1 Replies Last post: Nov 12, 2013 10:59 PM by Yegor Yarko  
Frederik Ring Newbie 1 posts since
Nov 8, 2013
Currently Being Moderated

Nov 8, 2013 8:14 PM

grunt task is exiting with status 0 but does not finish

I'm trying to use a grunt.js task (building and cleaning a require.js based project) a part of my build process. It is starting up properly but somehow TeamCity will not let it finish. Strangely enough it will exit with a status code of 0. Also I can easily ssh into my machine and run the batch-file that I wrapped the command in with success.

 

Log output will look like:

 

[16:59:34][Step 4/4] Starting:  C:\Windows\SysWOW64\WindowsPowerShell\v1.0\powershell.exe -NoProfile -NonInteractive -ExecutionPolicy ByPass -Command - < C:\TeamCity\buildAgent\temp\buildTmp\powershell8538083257075072449.ps1
[16:59:34][Step 4/4] in directory: C:\TeamCity\buildAgent\work\8e9be3fbdb39feee\Proj.Name
[16:59:45][Step 4/4] [4mRunning "requirejs:compile" (requirejs) task [24m
[17:00:00][Step 4/4] Process exited with code 0

 

When I run the task manually I will geht a lot more output (i.e. listing of all the files).

 

I already tried using powershell, normal command line and splitting up the task in seperate tasks, all to no success.

 

Has anyone else ever encountered this or has any solution to this problem? Thanks!

Yegor Yarko JetBrains 1,834 posts since
May 5, 2004
Currently Being Moderated
Nov 12, 2013 10:59 PM in response to: Frederik Ring
Re: grunt task is exiting with status 0 but does not finish

Hi Frederik,

 

When reproducing the comamnd manualy please make sure you consider all the optinos in reproducing that according to our notes.

 

There is an issue with alike symptoms.

There are soe workarounds suggested, but so far the root cause is not completely clear.

More Like This

  • Retrieving data ...