1 Replies Last post: Jan 31, 2014 8:47 PM by Fedor Buyvol-Kot  
Bob Van Roekel Newbie 3 posts since
Dec 14, 2011
Currently Being Moderated

Jan 10, 2014 9:38 PM

CI DotCover -3 ReturnCode

We are using CruiseControl, nant, nunit and dotCover for our CI build tasks.

 

I just got dotCover installed on the build server and ran the unit tests and coverage analysis. I am getting a return code of -3. Some of the unit tests are failing (which is ok at this point) but I am wondering if the -3 is because of the unit test failures? I can see in the Nant Output that the unit tests ran and everything looks good. Here are the last few lines from the NantOutPut:

...
[exec]                 Tests Not Run:
[exec]                 1) Ignored : CS.Services.NetSuiteService.Tests.NetSuiteServiceTests.DeleteSpecificJournalEntryValidInternalId
[exec]                 2) Ignored : CS.Services.NetSuiteService.Tests.NetSuiteServiceTests.SendJournalEntryValidMaxEntries
[exec]                 3) Ignored : CS.Services.NetSuiteService.Tests.NetSuiteServiceTests.TestResetPassword
[exec]                 Coverage session finished [1/10/2014 11:21:12 AM]
[exec]                 Analysed application exited with code '5'
[exec]                 Coverage results post-processing started [1/10/2014 11:21:12 AM]
[exec]                 Coverage results post-processing finished [1/10/2014 11:21:13 AM]
[exec]                 Report generation started [1/10/2014 11:21:13 AM]
[exec]                 Report generation finished [1/10/2014 11:21:16 AM]
[exec]                 e:\CCNet\SVNCheckouts\dev\trunk\CS_2.0\Q4.0-03\WebService\CS.WebService.NetSuiteService\NAnt3.build(169,8): External Program Failed: dotCover.exe (return code was -3)

 

I basically get the same results when I run dotCover from the console on my local drive, only difference is that I dont get the "External Program Failed: dotCover.exe (return code was -3"

Here are the results when I run it locally from the command prompt:

 

Tests Not Run:
1) Ignored : CS.Services.NetSuiteService.Tests.NetSuiteServiceTests.DeleteSpecificJournalEntryValidInternalId
2) Ignored : CS.Services.NetSuiteService.Tests.NetSuiteServiceTests.SendJournalEntryValidMaxEntries
3) Ignored : CS.Services.NetSuiteService.Tests.NetSuiteServiceTests.TestResetPassword

[JetBrains dotCover] Coverage session finished [1/10/2014 10:32:22 AM]
[JetBrains dotCover] Analysed application exited with code '3'
[JetBrains dotCover] Coverage results post-processing started [1/10/2014 10:32:22 AM]
[JetBrains dotCover] Coverage results post-processing finished [1/10/2014 10:32:23 AM]
[JetBrains dotCover] Report generation started [1/10/2014 10:32:23 AM]
[JetBrains dotCover] Report generation finished [1/10/2014 10:32:24 AM]

 

I dont get any error code return, it just comes back to the dos command prompt.

 

So is the error code just informing me that some of the unit tests failed?

Fedor Buyvol-Kot JetBrains 94 posts since
Dec 9, 2011
Currently Being Moderated
Jan 31, 2014 8:47 PM in response to: Bob Van Roekel
Re: CI DotCover -3 ReturnCode

Hi Bob,

The error code "-3"  indicates that the exit code in the application being analysed isn't equal to 0.

Please let us know if you have further questions.

 

Regards.

More Like This

  • Retrieving data ...