This Question is Answered

1 "correct" answer available (4 pts) 2 "helpful" answers available (2 pts)
3 Replies Last post: Jun 11, 2014 2:35 AM by Andriy Bazanov  
Jason Lefkowitz Newbie 2 posts since
Jun 13, 2012
Currently Being Moderated

Jun 11, 2014 12:19 AM

Completely turning off HTML/XHTML tag completion

This is the sort of question I feel stupid for asking, because almost certainly it's just due to me missing a checkbox in the options somewhere. But...

 

Is there any way to tell PhpStorm that I really don't want it to complete my HTML tags for me?

 

I've unchecked all the seemingly relevant options in the IDE preferences (Editor > Smart Keys > Automatically insert closing tag, Emmet > Enable XML Emmet, etc.), but still, when I type an opening DIV tag and then start to type the closing tag, PhpStorm completes the closing tag as soon as I type the slash. Which is really frustrating since I'm used to just typing it myself, so having PhpStorm "help" me throws off my typing rhythm.

 

Like I said, I'm sure this is just a case of operator cluelessness, so any enlightenment that can be offered would be gratefully received.

Andriy Bazanov Master 3,913 posts since
May 28, 2010
Andriy Bazanov Master 3,913 posts since
May 28, 2010
Currently Being Moderated
Jun 11, 2014 2:36 AM in response to: Jason Lefkowitz
Re: Completely turning off HTML/XHTML tag completion

I would not call it "a bug" (at all) -- but rather missing option / not implemented feature (at the end of the day "automatically insert closing tag" and "inserting closing tag after typing </" are two different things -- at very least for me; but yes -- they can make that option to be applied in both scenarious).

More Like This

  • Retrieving data ...