12 Replies Last post: Oct 28, 2011 3:02 AM by Aaron Rubin  
jaco Newbie 6 posts since
May 24, 2004
Currently Being Moderated

Jul 18, 2008 6:07 PM

svn authentication issue in 7905



I have an issue connecting to a svn repo over https and uses a certificate. It does not even ask for a password, just the message: svn: authentication cancelled. I have cleared the auth cache etc.. but still it does not ask for a password. Works as expected against a other non https repos


It worked fine in previous eaps.


Best Regards


Rayz Apprentice 905 posts since
Aug 27, 2002
Currently Being Moderated
Jul 21, 2008 3:08 PM in response to: jaco
Re: svn authentication issue in 7905

Can't really help I'm afraid, but I have noticed similar problems with the Diana EAPs. Accessing the repository through https does seem a little flakey. Now that I know it's not just me, I'll try to pin down the problem.

Irina Chernushina JetBrains 193 posts since
Jul 1, 2008
Currently Being Moderated
Jul 23, 2008 4:11 PM in response to: Rayz
Re: svn authentication issue in 7905



problem with SSL authentication using client certificate was fixed for both Diana and Selena. The fixes will be available in the next EAPs.

The problem was related to svnkit API change between versions.


Sorry for inconvinience.

Michael Duffy Newbie 89 posts since
Apr 12, 2006
Currently Being Moderated
Jan 27, 2010 2:20 AM in response to: jaco
Re: svn authentication issue in 7905

I started having this issue today.  My connection to Subversion was working fine yesterday, then I started getting "svn: authentication cancelled" and no prompt for a password.


I tried removing the repository and re-adding it - no effect.


I went to "File->Settings" and cleared my Subversion authentication cache - no effect.


I can log into the Subversion repo using Tortoise, so I know the URL exists, the listener is running, and my credential is valid.


I'm going to try blowing away the IntelliJ project tomorrow, doing a clean checkout from Subversion using Tortoise, and re-creating my IntelliJ project to see if that helps.


I'm using IntelliJ 9 version 93.54 running on Windows XP.

Jamie Krug Newbie 4 posts since
Jan 27, 2010
Currently Being Moderated
Jan 27, 2010 7:55 PM in response to: Michael Duffy
Re: svn authentication issue in 7905

Ditto. Yesterday all was well, today I'm getting this very same error. I'm just using local, file-based SVN repos. I'm running IDEA Ultimate 9.0.1 Build #IU 93.94 on Ubuntu 9.10 64-bit.


UPDATE 1: Oops! Just after submitting this, I noticed this thread is under EAP users. I'm not running an EAP build currently, but experiencing this same error just starting today...


UPDATE 2: Okay, this is strange, but I've fixed it. The first time I received this error, I noticed a balloon in the upper-right that included a "fix this" link, but I didn't click it fast enough and it did not appear when I tried again. I found that if I closed and reopened my project, it would show that message once, but it was very difficult to catch. After a few tries, I was able to click "OK" on the commit window and quickly hit Enter to dismiss the error dialog and then immediately click that "fix this" link. This gave me the usual dialog that allowed me to confirm/cache my SVN authentication.

Fredrik Wilhelmsen Newbie 1 posts since
Jan 29, 2010
Currently Being Moderated
Jan 29, 2010 10:40 AM in response to: Jamie Krug
Re: svn authentication issue in 7905

I also had problem with SVN after upgrading to 9.0.1.  A tried upgrading to IU-94.192, but to no avail.

I tried to catch the balloon you described, but I was not fast enough. A colleague pointed out a little red mark in the lower right corner.  I clicked on it and found the content of the balloon.

This solved my problem.

Randy Wilson Newbie 3 posts since
Sep 25, 2003
Currently Being Moderated
Apr 5, 2010 9:09 PM in response to: jaco
Re: svn authentication issue in 7905

I had this problem, and it turned out that there was a little tiny "pending notification" icon at the bottom right of the screen (the icon looks like a little piece of paper with a red warning spot on it).  When I clicked that, there was a notification with a "fix this" link on it.  Clicking that allowed me to enter my username and password for the subversion repository (I also clicked the "remember" button).  That fixed things right up.


This is hard to find, so I wish that you could do the same thing from either right where the error message is displayed ("authentication cancelled" or whatever), and/or from the subversion settings area.

Bryon McDowell Newbie 13 posts since
Aug 19, 2010
Currently Being Moderated
Sep 1, 2011 6:40 PM in response to: Randy Wilson
Re: svn authentication issue in 7905

I know this is an old thread, but this needs to be fixed.  I kept trying to commit and getting the "Authentication cancelled" error and couldn't figure out what was going on.  I had to drag our svn admin into it and spent a lot of time trying to figure out why I couldn't commit to svn.  The tiny warning bubble on the lower right is really unacceptable.  Upon an attempted commit, if the user isn't logged in a dialog should appear to allow them to log in.  I never noticed the warning bubble; instead I spent several minutes googling to find the answer.  Intellji IDEA deserves a better method of handling this issue.

bryan hunt Newbie 2 posts since
Sep 16, 2011
Currently Being Moderated
Sep 16, 2011 2:01 PM in response to: Bryon McDowell
Re: svn authentication issue in 7905

I'm putting in a bug report for this, I wasted an hour going through subversion config files before I found this posting - the little red icon is not a good way to communicate failed authentication. Subversion sucks, as most everyone has figured out by now but there's still a need to interoperate with legacy teams.



Irina Chernushina JetBrains 193 posts since
Jul 1, 2008
Currently Being Moderated
Sep 20, 2011 11:45 AM in response to: bryan hunt
Re: svn authentication issue in 7905

Ok, I will address issue http://youtrack.jetbrains.net/issue/IDEA-53015 for version 11


The problem is there's no session for Subversion, and any remote request to Subversion can fail because of authentication issues

(i.e. even not first request in a chain)

Out architecture does not allow us to raise authentication dialog at any moment and suspend _any_ background thread until credentials are given - it might cause a deadlock

(I'm writing that to show that the problem is not just about creating a dialog)


Neverhteless, the issue should be solved

bryan hunt Newbie 2 posts since
Sep 16, 2011
Currently Being Moderated
Sep 20, 2011 12:51 PM in response to: Irina Chernushina
Re: svn authentication issue in 7905



Thank you for your feedback. I can understand JetBrains' reluctance to countenance changes, potentially introducing deadlock; such as a lock stepped authentication dialog


The issue, nonetheless, causes confusion, and spoils the user experience for many people.


The warning icon at the corner of the screen is very small, and the warning does not flash in a sufficiently noticeable fashion to attract the users attention to the cause of the problem.


Perhaps a blocking problem, i.e - not being able to check out the source code for a unit of work is more deserving of a loud error - as opposed to a warning icon.


Best Regards,


Bryan Hunt

Aaron Rubin Newbie 2 posts since
Sep 30, 2009
Currently Being Moderated
Oct 28, 2011 3:02 AM in response to: bryan hunt
Re: svn authentication issue in 7905

Hi guys -


In PhpStorm (I'm using 2.1.4), it doesn't even prompt me for the ssh password.  The dialog which is spoken of in the bottom right corner does eventually get me to a dialog to enter in my user name, but NOT my password.  I don't see how it can authenticate without the password (I'm not using password-less rsa keys for security reasons).




- Aaron

More Like This

  • Retrieving data ...