4 Replies Last post: Mar 7, 2014 3:10 PM by Alex Andronov  
Alex Andronov Newbie 6 posts since
May 15, 2013
Currently Being Moderated

May 16, 2013 9:42 AM

Integration with GitHub. unable to download last version



Another bad experience with teamcity. Now I'm trying to get the sources from GitHub. Fortunately, the problem with out of memory was solved via internal property, but now I have another. After setting up fetch url, I always get an error:

Failed to build patch for build # {build id=34}, VCS root: https://github.com/xxx/xxx.git#master {instance id=10, parent id=1}, due to error: Cannot find commit XXXXXXXXXXXXXXXXXXXXXXX in repository  (C:\projects\ProjectFolder, https://xxxxxxx@github.com/xxxxxxx/xxxxxxx.git#master//xxxxxxx@github.com/xxxxxxx/xxxxxxx.git#master) jetbrains.buildServer.agent.impl.patch.PatchDownloaderImpl$1: Server was not able to build correct patch, most likely due to VCS errors


I tried to clone repository manually, tried to clean all and configure clean setting in VCS root, but still didn't have any luck with this. What I'm doing wron? What teamcity is doing wrong? Anybody have success story integrated teamcity with github?





PS. Honestly, I'm badly surprised after digging into teamcity details. Issue with Mono (still not answered), a lot of manipulations with internal properties for out of memory. Guys, you are doing cool tools but unfortunatelly only very simple steps are working fine (get sources from tfs and build solution). Any other task, which is different lead to huge problems. Most of the time it is really difficult to find an answer.

Michael Kuzmin JetBrains 1,561 posts since
Jul 30, 2005
Currently Being Moderated
May 23, 2013 4:36 PM in response to: Alex Andronov
Re: Integration with GitHub. unable to download last version



I'm sorry for the inconvenience.

Teamcity is compatible with GitHub, but the problem you've met is not a known issue, so we'll need to troubleshoot it together.


Could you please send us privately to teamcity-feedback@jetbrains.com the next info:

- Screenshots of VCS settings and VCS Root pages

- Debug VCS logs: go to Administration > Diagnostics page, and switch Logging preset to debug-vcs, start new build, reproduce the error, and get teamcity-vcs.log file.


Thank you.

Gleb Chermennov Newbie 2 posts since
Mar 7, 2014
Currently Being Moderated
Mar 7, 2014 2:30 PM in response to: Michael Kuzmin
Re: Integration with GitHub. unable to download last version

I'm experiencing this issue now.

Failed to start build #5 on <machineName>
Failed to build patch for build #y {build id=x}, VCS root: "ProjectName" {instance id=26, parent internal id=1, parent id=ProjectRoot, description: "https://github.com/url#branch"}, due to error: Cannot find commit <commit_hash> in repository (C:\...\system\caches\git\git-FB223D0E.git, https://accountName@github.com/url#master).
Any updates on this?

More Like This

  • Retrieving data ...