This Question is Not Answered

1 "correct" answer available (4 pts) 2 "helpful" answers available (2 pts)
0 Replies Last post: Jun 26, 2013 8:30 PM by jpelly  
jpelly Newbie 20 posts since
Aug 22, 2002
Currently Being Moderated

Jun 26, 2013 10:03 PM

Run RubyMine 5 on 32-bit Java on Mac OS?

I'm trying to run Rubymine 5.4 on 32bit Java (need the extra memory room). Looking at my java version:


> /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Commands/java -d32 -version

java version "1.6.0_51"

Java(TM) SE Runtime Environment (build 1.6.0_51-b11-456-11M4508)

Java HotSpot(TM) Client VM (build 20.51-b01-456, mixed mode)


Which indicates a 32 bit version.


In Info.plist, I changed:







(completely removed x86_64)
And I added "-d32" to the top of idea.vmoptions:
> cat /Applications/
But when I run Rubymine I still get 64 bit server edition:
Screen Shot 2013-06-26 at 12.29.02 PM.png
How can I force the 32 bit java instance?
Version info:

RubyMine 5.4.2, build RM-129.512.

Mac OS X 10.7

More Like This

  • Retrieving data ...